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Sensors & Software Inc. Product License, Copyright, Liability and 
Warranty Information 

Important 

Please read this document carefully before using the SOFTWARE PRODUCT or assembling the HARDWARE 

PRODUCT. By using the storage media or assembling the hardware, you are agreeing to be bound by the 
terms of this agreement. If you do not agree to the terms of this agreement, promptly contact Sensors & 
Software, Inc. at the address indicated at the end of this document. 

Definition 

The word PRODUCT as used herein defines any item sold by Sensors & Software, Inc. and may be 
comprised of HARDWARE PRODUCT which consists of physical objects and SOFTWARE PRODUCT which 
means computer programs, codes and related support materials. 

Software Product License Agreement 

In order to preserve and protect its rights under the applicable laws, Sensors & Software, Inc. does not 
sell any rights to its Software products. Rather, Sensors & Software, Inc. I grant the right to use its 
software, CDs, memory sticks (or other storage media) and documentation (hereafter collectively called 
SOFTWARE PRODUCT) by means of a SOFTWARE PRODUCT license.  You acknowledge and agree that 
Sensors & Software, Inc. retains worldwide title and rights to all its software and that the SOFTWARE 

PRODUCT contains proprietary materials protected under copyright, trademark and trade secret laws. 

Grant of Software Product License 

In consideration of payment of the license fee which is the price you pay for the SOFTWARE PRODUCT and 
your agreement to abide by the terms and conditions of this License Agreement, Sensors & Software, Inc. 
grants to you, the Licensee, a non-exclusive right to use the SOFTWARE PRODUCT under the following 
conditions: 

You may: 

¶ use the SOFTWARE PRODUCT on a single workstation owned, leased or otherwise controlled by you; 

¶ copy the SOFTWARE PRODUCT for backup purposes in support of your use of the product on a single 
workstation. 

You may not: 

¶ copy, distribute or sell copies of the SOFTWARE PRODUCT or accompanying written materials, 
including modified or merged SOFTWARE PRODUCT to others; 

¶ sell, license, sublicense, assign or otherwise transfer this license to anyone without the prior written 
consent of Sensors & Software, Inc.; 

¶ modify, adapt, translate, decompile, disassemble, reverse engineer or create derivative works 
based on the SOFTWARE PRODUCT. 

Termination 

This license is effective until terminated. You may terminate the license at any time by returning the 
SOFTWARE PRODUCT and all copies to Sensors & Software, Inc.  The license will automatically terminate 
without notice by Sensors & Software, Inc. if you fail to comply with any terms or conditions of this 
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agreement.  Upon termination, you agree to return all copies of the SOFTWARE PRODUCT to Sensors & 
Software, Inc. 

Update Policy 

Sensors & Software, Inc. may create, from time to time, updated versions of its SOFTWARE PRODUCT.  At 
its option, Sensors & Software, Inc. will make such updates available to licensees who have paid the 
update fee. 

Product Warranty, Limited Remedy and Limited Liability  

Sensors & Software, Inc. warrants the PRODUCT to be free from defect in material and workmanship under 
normal use for a period of one year (365 days) from the date of shipment.  Any third-party computer 
systems or other items not manufactured directly by Sensors & Software, Inc. purchased with any  

PRODUCT or independently from Sensors & Software, Inc. are subject to the original manufacturer's 
warranty and are not the responsibility of Sensors & Software, Inc. 

Sensors & Software, Inc. makes no other warranties including, but not limited to, any implied warranty of 
merchantability or fitness for a particular purpose.  If the PRODUCT is defective within the warranty period 
stated above, your exclusive remedy shall be, at Sensors & Software, Inc.ôs option to replace or repair the 
Sensors & Software, Inc. PRODUCT or refund the purchase price of the Sensors & Software, Inc. 
product.  Except where prohibited by law, Sensors & Software, Inc. will not be liable for any loss or 
damage arising from this Sensors & Software, Inc. product, whether direct, indirect, special, incidental or 
consequential regardless of the legal theory asserted. 

All statements, technical information, and recommendations related to any Sensors & Software, Inc. 
PRODUCT are based on information believed to be reliable, but the accuracy or completeness is not 
guaranteed.  Before using any PRODUCT, you must evaluate it and determine if it is suitable for your 
intended application.  You assume all risks and liability associated with such use.  Any statements related 
to the PRODUCT, which are not contained in Sensors & Software, Inc. current publications, or any 
contrary statements contained on your purchase order shall have no force or effect unless expressly 
agreed upon, in writing, by an authorized officer of Sensors & Software, Inc. 

Sensors & Software, Inc. warrants the CD, memory stick or other storage media on which the SOFTWARE 
PRODUCT is furnished to be free from defects in material and workmanship under normal use for a period 
of ninety (90) days from the date of purchase as evidenced by a copy of your invoice. 

Except as specified above, any SOFTWARE PRODUCT is provided "as is" without warranty of any kind, either 
expressed or implied, including, but not limited to, the use or result of use of the product in terms of 
correctness, accuracy, reliability, currentness or otherwise. The entire risk as to the results and 
performance of the PRODUCT is assumed by you. If the PRODUCT is defective or used improperly, you, and 
not Sensors & Software, Inc. or its dealers, distributors, agents, or employees, assume the entire cost of 
all necessary servicing, repair or correction. 

Sensors & Software, Inc.'s entire liability and your exclusive remedy for SOFTWARE PRODUCT shall be, at 
Sensors & Software, Inc.'s option, either: 

¶ the replacement of any storage media (CD, memory stick etc.) or hardware components which do 
not meet Sensors & Software, Inc.'s Limited Warranty and which are returned to Sensors & 
Software, Inc. postage prepaid with a copy of the receipt, or 

¶ if Sensors & Software, Inc. is unable to deliver a replacement storage media which is free of 
defects in material or workmanship, Licensee may terminate this agreement and have the license 
fee refunded by returning all copies of the SOFTWARE PRODUCT postage prepaid with a copy of the 
receipt. 
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If failure of any PRODUCT resulted from accident, abuse or misapplication, Sensors & Software, Inc. shall 
have no responsibility to replace the SOFTWARE PRODUCT, refund the license fee, or replace or repair the 
HARDWARE PRODUCT. 

Do not tamper with any PRODUCT.  PRODUCT contains no user serviceable parts.  If tampering is 
evident in Sensors & Software, Inc.ôs opinion, warranty is void and null. 

No oral or written information or advice given by Sensors & Software, Inc., its dealers, 
distributors, agents or employees shall create a warranty or in any way increase the scope of this 
warranty and you may not rely on any such information or advice. 

Neither Sensors & Software, Inc. nor anyone else who has been involved in the creation, 
production or delivery of the PRODUCT shall be liable for any direct, indirect, special, exemplary, 
incidental or consequential damages, claims or actions including lost information, lost profits, or other 
damages arising out of the use or inability to use this PRODUCT even if Sensors & Software, Inc. has been 
advised of the possibility of such damages. 

This warranty gives you specific rights.  You may have other rights which vary from province to province, 
territory to territory and certain limitations contained in this limited warranty may not apply to you. 

General 

No right, license, or interest to any Sensors & Software, Inc. trademarks is granted hereunder with the 
purchase of the PRODUCT or the SOFTWARE PRODUCT license. 

Governing Law 

In the event of any conflict between any provision in this license agreement and limited warranty and any 
applicable provincial legislation, the applicable provincial legislation takes precedence over the 
contravening provision.  This agreement shall be governed and construed in accordance with the laws of 
the Province of Ontario, Canada. 

Serviceability 

Should any term of this agreement be declared void or not enforceable by any court of competent 
jurisdiction, the remaining terms shall remain in full effect. 

Waiver 

Failure of either party to enforce any of its rights in this agreement or take action against any other party 
in the event of a breach of this agreement shall not be considered a waiver of the right to subsequent 
enforcement of its rights or actions in the event of subsequent breaches by the other party. 

Acknowledgement 

You acknowledge that you have read this agreement, understand it and agree to be bound by its terms 
and conditions. You further agree that this agreement is the complete and exclusive statement of 
agreement between the parties and supersedes all proposals or prior agreements oral or written between 
the parties relating to the subject matter of this agreement. 

Should you have any questions concerning this agreement, please contact in writing: 

 

 

 



EKKO_Project Userôs Guide Sensors & Software Inc. Product License, Copyright, Liability and Warranty Information 

 

 
6 

Sensors & Software Inc. 

1040 Stacey Court 

Mississauga, Ontario 

Canada L4W 2X8 

Tel:(905) 624-8909 

Toll Free: 1-800-267-6013 

Fax:(905) 624-9365 

E-mail: customerservice@sensoft.ca 

Sensors & Software, Inc. trademarks are listed at: www.sensoft.ca/trademarks 

1999-00236-05 
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This product uses libkml, a google Inc. software library which is subject to the following conditions of use. 

Copyright 2008, Google Inc. All rights reserved.  

1. Redistributions of source code must retain the above copyright notice, this list of conditions and the 
following disclaimer.  

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and the 
following disclaimer in the documentation and/or other materials provided with the distribution.  

3. Neither the name of Google Inc. nor the names of its contributors may be used to endorse or promote 
products derived from this software without specific prior written permission.  

THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED 
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO 
EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, 
EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, 
PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR 
BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER 
IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING 
IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF 
SUCH DAMAGE.  
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1  Introduction  
EKKO_Project was designed to simplify the display, editing, processing, and 
interpretation of Ground Penetrating Radar (GPR) data.  

EKKO_Project increases productivity by giving you more time to view and interpret data 
and less time spent organizing it. 

Use EKKO_Project to display project (.gpz) files (compressed files containing GPR 
linesets and grid data) intuitively in the Project Explorer window. The Properties tabs 
display GPR line details such as acquisition parameters and attached files.   

The Line Preview window automatically displays the first line in the project with the view 
settings from the data acquisition software or default view settings.  The user can display 
other lines by clicking on the line name in Project Explorer or using the arrow keys. 

The MapView window displays the position of grids in the project space coordinate 
system.  If GPR data was collected with GPS or, if the relationship between the project 
coordinate system and the global coordinate system (Latitude-Longitude or UTM) is 
defined by the user, grids and the GPS path of GPR lines are displayed in MapView. 

Depth slices processed in the field using the data acquisition software or using the 
optional SliceView module (see below) are also displayed in the MapView window.  

The optional LineView module allows you to display one or more GPR lines and modify 
the view settings to use different color palettes, gains, fonts, axes, etc.  See the 
LineView Module Userôs Guide for more details. 

The optional Interpretation module in LineView is used to create interpretations of 
Points, Polylines, Boxes, and Annotations, view them in GPR lines, and then output your 
interpretations as Reports. Interpretations are also displayed in MapView.  See the 
LineView Module Userôs Guide for more details. 

The optional SliceView module allows GPR data with 2-dimensional positioning, such as 
GPS or XY, to be processed and display as a series of depth slices. SliceView-Grid is 
used to process grid data into depth slices while SliceView-Line processes or one or 
more GPR lines into depth slices.  Depth slices enhance interpretations at complex sites 
by providing a powerful way of visualizing the spatial relationships between targets seen 
in multiple GPR lines.  SliceView also allows grid data to be exported in a 3D format.  
See the SliceView manual for more details. 

The optional Processing module allows you to edit and process data, including cropping 
data, time filters, migration and gain. You can then save processing streams as Recipes 
that you can apply to other GPR projects. See the Processing Module Userôs Guide for 
more details. 

The optional Bridge Deck Condition Report module allows you to process point 
interpretations on the rebar in a bridge deck or other concrete structure and output a 
PDF report with an amplitude map image and statistics about the rebar in the structure. 

The optional Pavement Structure Report module allows you to process polyline 
interpretations on subsurface layers and output a PDF report with cross-sections of and 
statistics about of the layers. 
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2  Getting Started  
EKKO_Project works with GPR project files called GPZ files. Each project file contains 
one or more GPR line data files and may contain information from other related files 
such as GPS files that were saved as the GPR data was collected.  

New generation Sensors & Software GPR devices automatically create Project files 
however, GPR data collected using older Sensors & Software GPR systems can easily 
be added to a new EKKO_Project project file following the Creating a New Project 
procedure. 

2.1  Project (GPZ) File Size Limits  

Project (GPZ) files are limited to a maximum size of 2 GB.  This includes the GPR data 
plus all the attachments (see Attachments Tab).  If you try to save a project file and get 
an error message that the project file is too large to save, consider deleting large 
attachments. 

2.2  Opening a Project  

When you open EKKO_Project, the Getting Started dialog box automatically opens to 
help you open or create a new project based on the data file format you select.  

 

Figure 1: The Getting Started dialog box 
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 Open a Recent EKKO_Project File  

1. In the Getting Started dialog box Open Existing Project pane, click the Recent 
Projects drop-down list. 
 

2. In the drop-down list, click the project file you want to open. 
 

 
 
 

 Open an Existing  EKKO_Project File  

1. In the Getting Started dialog box Open Existing Project pane, click 

 
 

2. In the Open dialog, navigate to the folder and select the project file you want to work 
in.  

 

Figure 2: Open Dialog 

Only files with a .gpz extension are listed.  

3. Select the project you want to work with and then click Open. 

The project contents are displayed in the Project Explorer and, if positioning 
information is available, the GPR lines are displayed in MapView. 
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If the project file contains grids that donôt have a global position reference such as 
GPS, a message appears: 
 

 
 

Answering Yes will tile the grids so they are not all plotted at the origin of the project 
coordinate system in MapView. 
 
Grids can be manually repositioned using the Grid Position Relationship in the Tools 
menu.  

2.3  Creat ing  a New Project  

To create a new EKKO_Project file (typically for older GPR systems that do not 
automatically generate project (.gpz) files), in the Create a New Project pane, select 
one of the following options: 

¶   
¶  
¶  

A project file can contain multiple grids and line sets. 

 Add ing a Grid  

1. In the Getting Started dialog box Create a New Project pane, click . 
2. In the Open dialog box, navigate to and then select a grid (.gfp) file.  

Only files with a .gfp extension are listed. For more details about GFP files, see Add 
Grid. 

3. Click Open. 
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The grid is displayed in the Project Explorer and indicated with the small green grid 
on the folder. 
 
 

 
 

 Add ing  a ll Lines in Folder  

1. In the Getting Started dialog box Create a New Project pane, click
.  

2. In the Select folder to import lines from dialog box, navigate to and then select a 
folder containing GPR lines. 

3. Click Select Folder. 

The new project folders will be displayed in the Project Explorer 

 Add ing  Line ( s)  

1. Click . 

2. In the Open dialog box, navigate to and then select one or more GPR (.hd) Lines.  

Only GPR files with an .hd extension are listed. 

Note: although only .hd files are listed and selected, the folder must also contain the 
associated .dt1 file(s). 

3. Click Open. The Line(s) are displayed in the Project Explorer  
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3  EKKO_Project Inte rface  Overview  
When a project file is open, EKKO_Project is populated with information about the GPR 
data in the Project file.  

 

 

Figure 3: The EKKO_Project interface  

The main EKKO_Project window consists of a Menu Bar, Toolbars, Project Explorer, 
Line Preview, MapView, Layer View, Status Bar and Properties tabs.  

All windows can be moved, resized, and modified. The tabs that make up the Properties 
window can be separated into individual windows (to learn more, see Window 
Operations). 

When a project file containing grid data is opened, the 3D Preview window is available to 
display the grid data in a 3D format with one depth slice and two GPR cross-sections 
(lines) visible at the same time.   

Menu Bar 

MapView 

Toolbars 

Project Explorer 

Properties Tabs 

Line Preview  

Layer View 

Status Bar 
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Figure 4: The EKKO_Project interface showing the 3D Preview window for grid data; in this example, a 
Conquest grid scan data. 

The GPR lines are oriented parallel to the cross-hair lines on the depth slice. 

For the details of the 3D Preview window, see 3D Preview. 

3.1  Active Window  

EKKO_Project typically displays several windows at a time including Line Preview, 
MapView and 3D Preview. Only one window can be active and accept changes at a 
time. The active window is the one that was last selected by clicking in it with the mouse 
cursor and is usually identified by its darker title banner.  

To make changes in a particular window, first ensure it is the active window. 

Trying to edit a window makes it the active window, for example, selecting a GPR line in 
the Project Explorer by clicking on it makes the Line Preview window the active window. 

3D Preview 
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4  Project Explorer  
Project, folders, and files are displayed in the Project Explorer which is similar to 
Windows Explorer. In Project Explorer, grids and linesets are used just like folders in 
Windows, and GPR lines are similar to files. 

To display all GPR Lines associated with a project folder, click the plus sign (+) beside 
the grid or lineset name  

 

Figure 5: Project Explorer pane displaying open data folders listing the GPR lines. 

The names of all the GPR data files in the grid and/or linesets are listed. The line icon (
) indicates which files are GPR lines. If other files associated with the line (photos, 

videos, field notes, etc.) have been attached, the line icon displays a paperclip icon 

 (to learn more, see Attach a File). 

Project Explorer 

Toolbar 

Lineset name 

Selected GPR line GPR Line icon 

Attachment icon 

t = topography data added 
i = Interpretations added 

g = collected with GPS  

p = processed 

Grid Name 

Pin window to frame 
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4.1  Data Collections Linesets vs. Grids  

Data collections in EKKO_Project are composed of either linesets or grids.  

Grids are, by definition, a complete collection of GPR lines related to one another 
spatially and run orthogonally (right angles) to one another; they cannot run at angles 
other than right angles.   

To edit a grid by adding, deleting, moving, or changing the direction of lines, use the 
Tools > Grid Tools > Grid Tools or by right-clicking on the grid name in Project Explorer 
and selecting Edit Selected Grid from the menu.  However, individual GPR lines in a grid 
can be copied from a grid and added to a lineset. 

Linesets are collections of GPR lines that may or may not relate to one another 
spatially. Linesets can be edited to add or delete GPR lines using the Right Click menu. 
GPR lines in linesets can also be cut and/or copied and pasted into other linesets.   

4.2  Selecting vs. Checking G PR Lines  

GPR lines, linesets, grids, and projects can be selected in two different ways: 

 Clicking the Item Name  

To select the name of a GPR line, lineset, grid, or project, click the item name.  

Once an item is selected, it is highlighted blue and you can only apply Right Click menu 
operations to the item. 

 

If the GPR line is displayed in MapView, it turns red to indicate it has been selected.  For 
example, if a single GPR line collected with GPS is selected, the GPS path in MapView 
turns red.  If a grid is selected, all the grid lines turn red. 

When a GPR line is selected in Project Explorer, it is displayed in the Line Preview 
window. 

 

  

Selected Line 
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 Clicking the Item Checkbox  

To access copy, cut, paste, delete, and process operations from the Standard Toolbar or 
the Edit Menu, click the checkbox beside the GPR Line, lineset, grid, or project name.   

Note: When a GPR Line is checked, the GPR collection (lineset or grid) and the 
project name are also checked. This feature enables you to identify when GPR Lines 
in the collection are checked even if the GPR collection is collapsed (click the minus 
sign [-]). 

 

4.3  Associated Data Files  

An icon is displayed next to the line name in Project Explorer to indicate whether any of 
the following file types are attached to the GPR line: 

 GPS 

If a GPS is connected to the GPR system during data collection, GPS files with the same 
name as the GPR line are saved to the Project file and/or data folder.  When the GPR 
data is opened in EKKO_Project, GPS positions are automatically integrated with the 
GPR lines.  This is indicated by the letter ñg,ò see the example in the Project Explorer.  

GPS integration means Latitude-Longitude and UTM coordinates are displayed on the 
Status Bar when viewing the GPR line in LineView and listed in Reports.   

The name of the GPS file is listed under the Attachments tab.  

 Topography  

When a topography (.top) file with elevation information is attached to a GPR line, it is 
indicated by the letter ñt,ò see the example in the Project Explorer. 

Integrating topography information means that the GPR line can be plotted with an 
elevation axis in LineView, rather than the default depth axis.  Elevations of 
interpretations and fiducial markers are also listed in Reports. 

The topography file name is listed in the Attachments tab.  

Topography files with the same name and in the same folder as the GPR line are 
automatically attached.  Topography files with a different name can be manually 
attached; see the Attachments tab.   

GPS files also contain elevation information; see GPS Files for more information about 
GPS elevations and how EKKO_Project decides whether to use Topography file or GPS 
file elevations.  

 Interpretations  

Interpretations added to the file using the optional Interpretation module in LineView are 
identified by the letter ñi,ò see the example in the Project Explorer. Interpretations are 
points of interest (points, polylines, boxes, and annotations) added to GPR lines. This is 
similar to adding a flag/fiducial during data collection. 

file:///C:/My%20Documents/Manuals/EKKO_Project%20V3%20R2-2011-00125-06/Source/Text/EKKO_Project%20manual.docx
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 Processing  

GPR data that has been processed using the optional Processing module is identified by 
the letter ñp,ò see the example in the Project Explorer.  See the Processing Module 
Userôs Guide for more details. 
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5  Project Explorer Toolbar  
The Project Explorer toolbar displays four icons representing features that enable you to 
add GPR lines to the current project: 

 

5.1  Ad d a New Lineset  

1. To add a new lineset folder to the current project file, in the menu bar click .  

A  folder opens in the Project Explorer.  

2. To rename the new lineset, right-click New Lineset. 
3. In the drop-down list, click Rename.  

5.2  Add a Grid  

1. To add a grid (.gfp) file to the current project, in the menu bar click . 
2. In the Open dialog box, navigate to the folder and click the grid file you want to open.  

Only files with a .gfp extension are listed. 

3. Click Open. 

The new grid is displayed in the Project Explorer: 

 

5.3  Add Lines to Lineset  

1. To add lines to the selected lineset, in the menu bar, click . 
2. In the Open File dialog box, navigate the file folder and then select one or more 

GPR (.hd) Lines.  

The GPR lines are added to the current Lineset. If the highlighted item is not 
contained in a lineset, a new lineset will be created in the project.   

Note: GPR lines cannot be added to a grid. 
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3. Click Open. 

The lines are displayed in the Project Explorer: 

 

5.4  Attach a File  

The Attach File feature enables you to attach any file to the selected GPR line, lineset, 
grid, or project.  

Note: any item with the same name as the line is automatically attached when the 
line is added to the project (for example, a picture of the site could be renamed as 
LineX0.jpg so it is automatically attached to the project when the LineX0 data is 
added). 

1. To add an attachment to a file, in the menu bar click Attach File . 
2. In the Open File dialog box, navigate to the folder and then select the file you want 

to attach.  
3. Click Open. 

The files are displayed in the Attachments pane: 

 

Note: if you attach multiple topography (.top) or GPS (.gps or .gp2) files, the last file 
attached is the one that is used. 

5.5  LineView  Module (Optional)  

Double-clicking on a GPR Line name in Project Explorer displays it in the optional 
LineView module.  For more details, see LineView or the LineView module Userôs Guide. 

5.6  SliceView  Module (Optional)  

The SliceView module processes grids or lines into a series of depth slices.   

SliceView-Grid processes a grid into depth slices.   

SliceView-Lines processes one or more lines with 2D positioning (such as GPS or 
project XY) into depth slices. 

 SliceView -Gri d  

Use one of the following methods to process a grid in SliceView-Grid: 

1) Double-click on a GPR grid name in Project Explorer.   
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2) Select or check the grid name in Project Explorer and then select Tools > 
SliceView-Grid. 

3) Select or check the grid name in Project Explorer and then click the SliceView 

button  on the toolbar. 

4) Select or check the grid name in Project Explorer and then click the dropdown 
button beside the SliceView button on the toolbar and select SliceView-Grid. 

 

5) Right click on the grid name in Project Explorer and select SliceView from the 
sub-menu. 

 SliceView -Lines  

Use one of the following methods to process a single GPR line in SliceView-Lines: 

1) Select or check the line(s) in Project Explorer and then select Tools > SliceView-
Lines. 

2) Select or check the line(s) in Project Explorer and then click the SliceView button 
on the toolbar and select SliceView-Lines from the dropdown. 

For more details, see SliceView or the SliceView module Userôs Guide. 

5.7  Right Click Menu  

When you right-click in Project Explorer, a context-sensitive menu opens.  Menu items 
vary depending on whether the project name, a grid, lineset, or GPR line was right-
clicked on. 

Menu items in the right-click menu only operate on the item that was selected. The 
checked items in the Project Explorer are ignored. 
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Use the following table as a guide to working with the Project Explorer Right Click menu 
features: 

Menu Option Description 

LineView  Click LineView to open and display project GPR lines in the optional 

LineView module. 

To learn more, see the LineView Userôs Guide. 

The LineView button is only visible if the LineView module was 

purchased. 

SliceView-Grid Click SliceView-Grid to process and display the grid as a series of depth 

slices in the optional SliceView module. 

To learn more, see the SliceView Userôs Guide. 

The SliceView button is only visible if the SliceView module was 

purchased. 

SliceView-Lines Click SliceView-Lines to process and display the checked lines with 2D 

positioning as a series of depth slices in the optional SliceView module. 

To learn more, see the SliceView Userôs Guide. 

The SliceView button is only visible if the SliceView module was 

purchased. 

3D Preview  With a Conquest grid selected in the Project Explorer, click  to open 

and display the grid as a depth slice flanked with an X and Y line.  To 

learn more, see 3D Preview. 

 

Rename Change the name of the project, grid, lineset, or GPR line in a lineset. 

Note: A GPR line name in a grid cannot be renamed. 

Edit Selected Grid  Edit the selected grid. See Edit Selected Grid. 
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Menu Option Description 

Create Grid from 

Checked Lines 

Create a new grid using the checked lines in Project Explorer. See 

Create Grid from Checked Lines. 

Attach File To attach any file to the currently selected GPR data line, lineset, grid, 

or project, click   Attach File.  

The file is then displayed in the Attachments tab. 

Zoom To Zoom to the currently selected GPR line or grid in MapView.  The GPR 

line or grid must be plotted in MapView so only grid lines or lines with 

GPS are eligible or this option is greyed out and not accessible. 

Grid Position 

Relationship 

If a grid is selected, the grid-to-project position relationship is edited 

(see Grid Wizard) ï useful for moving a grid in the project XY coordinate 

system.   

Line Positioning If a line is selected, the line-to-project position relationship is edited (see 

Line Positioning) ï useful for defining or placing a line in the Project, 

Latitude/Longitude or UTM coordinate system.  

Note: the position of individual grid lines cannot be edited with this 

option; the options are greyed out and not accessible. The positions of 

grid lines are edited using the Edit Selected Grid tool. 

Process 
To open the Processing dialog box, click  Process.  

This feature enables you to edit and process selected GPR line using 

repositioning, temporal and spatial filters, and migration features.  

See the Processing module Userôs Guide for more details. 

Undo Process To reset the selected GPR line to its original format before processing 

was applied, click  For more details, see the Processing module. 

Undo Process.  

Copied GPR lines are reset to the any processing they had at the point 

they were copied.   

When processing is undone to an item, the small letter ñpò beside the file 

name indicating that it was a processed file disappears.   

See the Processing module Userôs Guide for more details. 

Average Trace 

Amplitude (ATA) 

Plot 

Average Trace Amplitude (ATA) plots display the average signal 
amplitudes (in millivolts) for the selected GPR line.  

ATA plots display how quickly signal amplitude decays from the peak 
value of the transmit pulse to the background noise level, providing an 
indication of the maximum penetration in the survey area. See Average 
Trace Amplitude. 

Average Frequency 

Spectrum (AFS) 

Plot  

Average Frequency Spectrum (AFS) plots the average frequency 
spectrum of the selected GPR line.  

Select AFS to determine the frequency content and bandwidth of the 
GPR line to decide if filtering is required. See Average Frequency 
Spectrum. 
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Menu Option Description 

Trace Plot Trace Plot is used to display individual traces from the selected GPR 
line; this allows the user to check the first break is correct, see subtle 
signals on traces or view the effect of different editing and processing 
types on individual traces. See Trace Plot. 

Cut 
Use the  Cut feature to remove the selected GPR line, lineset or grid 

from the project. 

This enables you to remove a GPR line from a lineset and paste it into a 

different lineset. 

Note: a GPR line cannot be cut from a grid. 

Copy 
Use the  Copy feature to: 

¶ Copy the selected GPR line so it can be pasted into the same or a 
different lineset in the project  

¶ Copy the selected lineset or grid so it can be pasted back into the 
project 

Note: You can copy GPR lines from a grid and paste then into a lineset, 

but you cannot be paste them into a grid. 

Paste 
Use the  Paste feature to: 

¶ Paste a copied or cut GPR line into the same or a different lineset 
in the project  

¶ Paste a copied or cut lineset or grid back into the project 

Note: You can copy GPR lines from a grid and paste them into a lineset, 

but you cannot paste them into a grid. 

Delete To Delete the selected grid or lineset from a project, click   Delete. 

You can also delete a GPR line from the Lineset in the project. 

Note: GPR lines cannot be deleted from a grid.  . 
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6  Line Preview  
The Line Preview window displays the GPR line currently selected in Project Explorer.  
When EKKO_Project first opens, Line Preview automatically displays the first GPR line 
listed in the project. 
 

 
 
If the GPR line is a Conquest line that includes PCD data, the PCD response is plotted 
as a red graph under the line image.  The maximum value of the PCD scale is displayed 
in the Line Preview Legend. 
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The user can change the Line Preview display to another GPR line in the project by: 
 

1) Clicking on another line name in Project Explorer, or 
 

2) After clicking in the Project Explorer window to make it the Active Window, using 
the up and down arrow keys on the keyboard to move to a new GPR line name. 

 
Both options provide fast switching between lines to quickly review all the lines in a 
project.   
 
Any Flags or Field Interpretations added to the GPR line during data collection or 
interpretations added to the GPR line using the optional Interpretation module are visible 
in the Line Preview plot. Clicking on a multi-media flag (one with a media icon such as a 
photo, audio or video) opens the file attached to the flag. 
 

 
 
On the bottom of the GPR line is a simple legend listing the file path and line name, the 
velocity used to calculate the depth axis and the View Settings (gain and filter). 
 
After selecting the Line Preview window, use the zoom options to zoom in, out or to a 
user-specified zoom window using the buttons on the View Control Toolbar or the View 
> Zoom menu options.  
 
After zooming in, plot the whole GPR line to the Line Preview window by selecting the 
Fit to Window button on the View Control Toolbar or the View > Zoom menu option. 
 
GPR lines plotted in Line Preview use the View Settings (gain, color table, filter, etc.) 
from the GPR systemôs data logger (DVL or Display Unit).  If these settings are not 
available, default settings that include Auto gain, the ñBoneò color palette and no 
background subtraction filter applied. 

Multi-media flag 
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The View Settings can be changed by plotting the GPR line(s) in the optional LineView 
module and changing the View Settings there.  After exiting LineView, the Line Preview 
settings for that GPR line are updated.   
 
Use Measure to measure distances between objects on a GPR images displayed in 
LineView.  The Measure tool includes the vertical component of the distance so be 
careful of the vertical exaggeration that is often a part of GPR data displays. 
 
If LineView module is not enabled, change the View Settings for the GPR line on the 
systemôs data logger (DVL or Display Unit) and transfer the data, along with the new 
View Settings, to the PC and open the updated project file in EKKO_Project. 
 
Line Preview will not plot GPR traces in wiggle mode and GPR lines cannot be plotted 
with an elevation axis with the traces shifted for topography ï these advanced display 
options are available in the LineView module. 
 
If the Line Preview window is closed, open it by selecting Window > Open Line 
Preview. 
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7  MapView  
The MapView window shows a plan map image of GPR lines and grids.  It also displays 
flags/fiducials, field interpretations, interpretations and depth slices added to the GPR 
data in the field or by using EKKO_Project.  The Layer View window controls which 
items are visible in MapView. 

 

 

 

 

Figure 6: MapView Window New image  
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If the GPR project does not contain any grids and none of the GPR lines were collected 
with GPS or positioned using Line Positioning, then the MapView window will not be 
open as there is nothing to plot. 

When one or more GPR lines are selected in the Project Explorer, they appear in red in 
MapView. If the file has an associated GPS file, the GPS path also appears in red. 

Flags always appear as a flag icon with text nearby.  Flags that have had a photo, audio 
or video file attached to them, called multi-media flags, appear with an appropriate icon 
with text nearby.  Clicking on the icon opens the attached file. 

 

Figure 7: Clicking on a multi-media flag in MapView, opens the file attached to the flag. 

 

Interpretations appear in the color and shape they were defined with. 

Depth slices can be plotted in MapView.  For more information, see below. 

7.1  Project (XY) Coordinates  

MapView displays GPR data in project (XY) coordinates.  The horizontal axis is the 
project X position, and the vertical axis is the Project Y position.  The units are either 
meters or feet, determined by the selected Units. 

GPR lines are displayed in MapView as black lines with arrows.  Lines collected as part 
of a grid are automatically displayed in MapView.  Individual GPR lines are displayed in 
MapView if they have project (XY) positioning added to them (see Line Positioning). 

Move the mouse cursor over the MapView image to display the project (XY) coordinates 
the Status Bar along the bottom of the EKKO_Project screen. 
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7.2  Global Coordinates  

To show GPR data in global coordinates, such as Latitude-Longitude or UTM, the 
relationship between the project (XY) and global coordinates must be defined.  If GPR 
data were collected with GPS, this relationship is automatically defined. 

If a grid was collected with GPS, the grid lines are displayed as black arrowed lines and 
the GPS paths are displayed as dark green lines (see Figure 6). Due to the variable 
accuracy of GPS units, the GPS lines will not typically correspond exactly with the GPR 
grid lines.  MapView calculates the best fit of the grid to the GPS to position the grid and 
establish the project ï global relationship.   

To manually define the Project to Global relationship, use the Tools > Project Position 
Relationship > Wizard (see Wizard). 

Once the Project to Global relationship has been defined, move the mouse cursor over 
the MapView image to display the Latitude-Longitude and UTM coordinates in the Status 
Bar along the bottom of the EKKO_Project screen. 

A compass icon  pointing to geographic North is displayed if the World-Project 
relationship is defined. This relationship is calculated automatically if the GPR data were 
collected with GPS.  If this relationship is not defined, the Status Bar displays ñGPS 
relationship not definedò. 

Global coordinates are also used in output reports (see Project Report (CSV)). 

If the GPS and grid lines are out by 45 degrees it may indicate a problem with the grid 
definition of ñXò and ñYò lines when the grid was collected in the field.  To correct, see 
Editing Grid Line Orientation. 
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Use the following table as a guide to working with MapView: 

Item Description 

Cross-hair position As you move the cursor over an area in the Grid Map, the position of 

the mouse cross-hair is displayed in XY and global coordinates GPS (if 

present) at the bottom right of the screen. 

Flags/Fiducials Flags/Fiducials are markers added during data collection at specific 

trace positions along the line.   

Flags/Fiducials can be repositioned and the labels edited if the 

Interpretation module was purchased (see the LineView Userôs Guide 

for more details). 

Interpretations Interpretations added to the file using the optional Interpretation module 

in LineView. 

Interpretations represent points of interest (points, polylines, boxes, 

and annotations) added to the line. To learn more, see Interpretations. . 

Field Interpretations Some GPR systems such as the LMX200 have the capability of adding 

point interpretations in the field.  These are just like the interpretations 

added with the Interpretation module and are displayed in MapView. 

Selected Line The line selected in the Project Explorer is highlighted red in the plan 

Map. The details of the selected line are displayed in the Properties 

Pane. 

Compass When the project-global position relationship is defined, a North arrow 

is displayed in MapView.  North is not necessarily vertically upwards; if 

a grid is opened, MapView displays it with the Y-axis pointing vertically, 

which may not be North so the North arrow will then point in another 

direction.  To rotate the MapView display so North is up, use the Reset 

to North function. 

7.3  Depth  Slices  in MapView  

Depth slice images can be plotted to MapView.  Depth slices are generated in two ways: 

1) Using the optional SliceView module or 

2) For some, generally more recent GPR systems, depth slices can be generated 
on the Display Unit or DVL during data collection out in the field.  For example, 
when using recent Noggin, LMX200 or Conquest systems, depth slices from grid 
data can be generated on the DVL.   
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Depth Slice generated and displayed on a Digital Video Logger.  These images are saved to the GPZ file 
when the data is copied to a USB-memory stick and available to display in EKKO_Project. 

Depth slices generated in the field are saved when the data is transferred from 
the DVL to the GPZ file on the USB-memory stick.  These depth slices are 
available to plot in MapView when the GPZ file is opened in EKKO_Project. 

The SliceView module can generate depth slices from: 

1. grid data (SliceView-Grid) 

2. GPR line data (SliceView-Lines) collected with GPS 

3. GPR line data (SliceView-Lines) that has XY positioning added each line in post-
processing using Line Positioning.   

4. GPR Lines made into a grid (Create Grid from Checked Lines). 

Depth slices are only displayed in MapView if they have been checked in the Layer 
View.  
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Depth Slice at 0.85 m generated from a grid and displayed in MapView. 

 

 

Depth Slice generated from one or more GPR lines and displayed in MapView. 

 

Slider bar 
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Use the depth slice slider bar on the top right of the MapView window, to scroll through 

the depth slices.  You can also use the mouse-wheel to smoothly scroll through the 

depth slices, after selecting the MapView window to make it the Active Window. 

The current slice depth is displayed next to the slider bar, the window title and the 

MapView legend in the top left corner. 

For multiple grids, slice through all of them simultaneously, even if: 

¶ they are at different angles to one another,  

¶ they were collected with different GPR systems with different center antenna 

frequencies,  

¶ they were collected with different depth slice processing (slice thickness, 

amplitude equalization gain, background subtraction filter, resolution, etc.).  

For example, if depth slices were processed using a different slice thickness value, the 

depth slices shown in MapView are the depth slices closest to the current depth value. 

 

 

7.4  Saving MapView Depth Slices as GIF 

Animation Files  

If the MapView window is the Active Window, select View > Export Animation to the 
depth slices to a GIF animation file.  The Export Animation dialog box allows the user to 
set the frame speed of the animation.  For more details, see Export Animation. 
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7.5  Displaying Multiple Grids with GPS  

Many GPR surveys are made up of multiple grids. EKKO_Project can display more than 
one grid to confirm targets within the grids. 

Multiple grids collected using GPS are automatically arranged within the MapView 
window.  

 

 

7.6  Repositioning Grids  

Multiple grids collected without GPS all have their X=0, Y=0 corner corresponding with 
the X=0, Y=0 of the Project coordinate system.  When a project file containing more than 
one grid without GPS is opened, the user is asked if they would like the grids arranged 
so they are spread out and do not overlap. 

Answering ñNoò will leave all the grids ñstackedò at the X=0, Y=0 position (see figure 
below below).   
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Answering ñYesò automatically shifts the grids so there is a gap between each one.    In 
other words, the origin of all grids after the first grid is set to a value other than X=0, Y=0.   

Regardless of the position of a grid in MapView, it can move to a new position. To move 
a grid within the project coordinate system, select the grid in Project Explorer and then: 

1) right-click to open the menu and select Position Relationship > Wizard or, 

2) select Tools > Grid Position Relationship > Wizard 

and follow the directions (see Grid Position Wizard). 

For example, the image below shows grids after each one was repositioned within the 
Project coordinate system. 

 

7.7  Editing and Merging Multiple Grids  

Use the Tools > Grid Tools to create grids from lines, edit grids, add lines to a grid or 
merge two grids together to create one large grid.   

The key advantage of using the Grid Tools to merge multiple grids together is that then 
all grid data are processed together in SliceView, so filters such as Background 
Subtraction use all the data in their calculations. 

Merging grids in Grid Tools requires the grid lines for all grids to be parallel or orthogonal 
(90 degrees) to one another.  You cannot merge grids if grid lines are oriented at other 
angles, for example, 45 degrees. 

As well, all the grids being merged must have consistent settings such as antenna 
frequency, temporal sampling interval, antenna separation, etc.  If any key settings differ 
between grids, they cannot be merged.  In this case where there are differences, it is 
better to plot the grids separately as shown in the sections above. 

For more details, see Adding a Grid to a Grid. 
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7.8  Background Image s 

A powerful way to visualize and present data is by adding a background image to 
MapView.   

 

 

For details, see Add Background Image to MapView. 
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8  Layer View  
The Layer View window allows the user to specify which items to display in MapView 
and Line Preview windows.   

 
 

Checked items are displayed in MapView and Line Preview.  

The checked status of Line Slices, Grid Slices, Lines, GPS, Flags/Fiducials and 
Interpretations are used to determine which elements to include in the Google Earth 
Report KMZ file (Google Earth (KMZ)).   

 

Use the following table as a guide when working with the Layer View window: 
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Layer Description 

Background Image Display the background image in MapView.  It is possible to display 

more than one background image, so they can be stacked on top of 

one another or spread out to different areas of MapView.  Individual 

images can be turned off or on using the checkbox.  When multiple 

images are displayed, the first image loaded is on the bottom and later 

images are displayed above.  If the image has a percentage of 

transparency, images underneath it will be partially visible. 

Right-clicking on a background image item opens a sub-menu.  

 

Selecting Settings opens the Add Background Image dialog (Add 

Background Images to MapView) 

Selecting Edit puts handles on the image to resize or rotate it and 

selecting Delete deletes the background image. 
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Line Slices Plot depth slices generated with the SliceView module using the 

SliceView-Lines program.  It is possible to display more than one Line 

Slice at the same time. If Line Slices overlap, they are displayed in 

alphabetical order with ones that start with, say ñzò, on top of ones that 

start with, say ñaò. 

Right-clicking on a Line Slice item opens a sub-menu.   

 

Selecting Settings opens the SliceView-Lines dialog to allow the 

settings for that Line Slice to be modified and the depth slices 

regenerated. 

Selecting Rename opens a dialog to rename the Line Slice. 

Selecting Delete deletes the Line Slice image. 

Grid Slices Plot depth slices generated with the SliceView module.  Depth slices 

generated with the SliceView-Grid program or, for some GPR 

systems, in the field with the data acquisition program. For example, 

the Conquest, LMX200 and Noggin systems generate depth slices in 

the field. 

For Conquest users, the PDC image is always plotted on top of depth 

slices so ensure Grid Slices is not checked when viewing grid slices.  

It is possible to display more than one Grid Slice at the same time. If 

Grid Slices overlap, they are displayed in alphabetical order with ones 

that start with, say ñzò, on top of ones that start with, say ñaò.. 

PCD Slice Plot Power Cable Detector (PCD) image in MapView. Only available 

for grid data collected with a Conquest GPR system. 

The PCD image is always plotted on top of depth slices so ensure 

PCD Slice is not checked when viewing the grid slices. 

Lines Plot GPR grid lines and GPR lines with project (XY) positioning in the 

MapView window. Grid lines plot on top of depth slices so turning the 

grid lines off makes the depth slices more visible. 

GPS GPS paths for lines and grids collected with a GPS in the MapView 

window. 
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Flags/Fiducials Markers added to GPR lines in the field during data collection.   

When selected, Flags/Fiducials are displayed in both the Line Preview 

and MapView windows.   

Flags/Fiducials are indicated by a flag icon and a label such as F1, F2 

etc.   

If the flag had a media file attached to it, it appears as a multi-media 

flag (see Line Preview and MapView).   

Flags/Fiducials can be repositioned, and the labels edited if the 

optional Interpretation module was purchased (see the LineView 

Userôs Guide for more details).  

Interpretations Display interpretations in MapView and Line Preview.  Interpretations 

are added to GPR lines while analyzing the data using the optional 

Interpretation module in LineView.  

Interpretations are points of interest (points, polylines, boxes, and 

annotations) added to GPR lines. 

GPR systems with the DVL 500 data logger, such as the LMX200, 

newer Noggins and pulseEKKOs have the capability of adding point 

interpretations in the field.  These are just like the interpretations 

added with the Interpretation module. 

Legend Display the Legend in the MapView window, defining the Flags and 

interpretations added to the data in the field or while analyzing the 

GPR data in EKKO_Project using the Interpretation module in 

LineView.  The legend also displays the current depth of depth slices.   

If the Legend is covering data, it can be moved by clicking and 

dragging it to a new location in the MapView window. 
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9  3D Preview  for  Grid  Data  
The 3D Preview window shows a depth slice image from a grid on the upper left, a GPR 
X line on the bottom left and a GPR Y line on the upper right.   

1. To display a grid in 3D Preview check or select a grid in Project Explorer. 

 

2. Click Window > Open 3D Preview. 
3. 3D Preview can also be opened from the Project Explorer right click menu  
 
Here is an example of a 4x4 foot grid on concrete floor collected with a Conquest 
system.   
 

.  

 

Images of the 3D Preview window can be saved to the project and used in the GPR 
Summary Report or exported to the clipboard or an image file.  They can also be saved 
as a GIF animation files (Export Animation)  

 

Y GPR Line 

X GPR Line 
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Depth Slice 
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Here is an example of a 12x30-meter archaeological grid collected with a Noggin 250 
system. 

 

 

For help with interpreting concrete, utility and geological data displayed in 3D Preview 
see Interpreting Grids in 3D Preview. 

 

The 3D Preview window is only available if the grid data has been processed into depth 
slices.  The depth slice processing is typically done using the SliceView-Grid function in 
the SliceView module.  However, GPR systems with the DVL 500 data logger can 
process depth slices right on the display unit out in the field, specifically the Conquest 
100, LMX200, Noggin and pulseEKKO have this capability.  These depth slices are 
saved with the GPZ file when it is transferred from the display unit and copied to a 
computer. 

9.1  Depth Slices  

The depth slice image displayed is controlled by the vertical slider bar beside the 
window, mouse wheel or Page Up and Page Down keys, and is locked to the same 
slice displayed in the MapView window.   

The red Depth Slice Cursor Lines indicate the depth slice thickness and the depth range 
of data used to calculate the current depth slice. 

Clicking in the depth slice image moves the crosshairs to the nearest X and Y lines. 

The Depth Slice images can be modified with different gains and color palettes by: 

X GPR Line 

Y GPR Line 

Legend 

Depth 
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Hairs 

Depth Slice Cursor Lines 

Depth Slice 
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1) Reprocessing the grid data in SliceView-Grids after changing the slice gain, data 
processing and/or the slice settings. 

2) Changing the settings and reprocessing the grid data on the Conquest 100, 
LMX200, Noggin or pulseEKKO Display Unit, exporting the new project file to a 
PC and opening it again in EKKO_Project, 

9.2  GPR Lines  

The GPR lines are displayed parallel to the crosshairs on the depth slice.  The Y line is 
rotated so it is parallel to the vertical crosshair. 

Change the current X line by pressing the Up Arrow and Down Arrow on the keyboard. 
Change the current Y line by pressing the Left Arrow and Right Arrow on the 
keyboard.  

As you move the cursor over the GPR Line images, the position and depth of the mouse 
crosshair is displayed at the bottom right of the screen. 

The GPR Line images can be modified with different gains, color palettes, depth, etc. by: 

1) Changing the Line settings in SliceView-Grids, saving the new settings and 
exiting. 

2) Changing the View Settings in the Conquest 100, LMX200, Noggin or 
pulseEKKO Display Unit, exporting the new project file to a PC and opening it 
again in EKKO_Project, 

9.3  PCD  

If displaying Conquest 100 data in 3D Preview, the PCD image replaces the current 
depth slice in 3D Preview by selecting it in the Layer View window: 
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9.4  Drill Locator  

The Drill Locator is displayed on the depth slice by selecting the Drill Locator button from 
the View > Drill Locator menu option or right-clicking on the 3D preview depth slice and 
selecting it from the menu.   

The Drill Locator is a set of movable crosshairs and a resizable circle displayed on the 
depth slice to determine the XY coordinates of a suitable location to drill.   

The diameter of the circle is set by the user with the View > Edit Drill Diameter menu 
option or by right-clicking on the 3D preview depth slice and selecting it from the sub-
menu:   

 

Enter a custom size of the drill diameter up to 36 inches or 1000mm. 

PCD 

Image 

PCD Response 
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9.5  Legend  

The Legend is in the lower right of the 3D Preview window.  It displays the depth of the 
displayed depth slice, the names of the displayed X and Y lines and drill locator XY 
position and diameter (if displayed). 

9.6  Saving GIF Animation  

If the 3D Preview window is the Active Window, select View > Export Animation to 
save it to a GIF animation file.  The Export Animation dialog box allows the user to select 
whether the depth, X lines or Y lines will animate while the other two are fixed on the 
currently selected image.  For more details, see Export Animation. 

9.7  Interpreting Grids in 3D Pr eview  

When interpreting data in 3D Preview it helps to remember that the images are 3 sides 
of a cube of data.  The conceptual grid image displays the relationship between depth 
slice images and X and Y GPR lines.  
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Use the following tips to help interpret grid data shown in 3D Preview for Grid Data: 

1) If the grid was collected with only lines in one direction, only one set of X or Y 
GPR lines will appear. 

2) The position of the Y line within the grid is indicated by the vertical cross-hair on 
the depth slice.  

3) The position of the X line within the grid is indicated by the horizontal cross-hair 
on the depth slice. 

4) The depth slice image shows an average of all the GPR signals between the two 
red depth slice cursor lines displayed in both the X GPR line and Y GPR line.  
Stronger colors usually indicate a stronger reflection and therefore, a higher 
contrast between the host material and the object. 

5) To change the depth slice to a shallower or deeper one, use the Depth Slice 
Slider bar on the right side of the window.  Notice how the Depth Slice Cursor 
Lines on the X and Y GPR lines move together. 

6) Use the Measure tool to measure the distance between objects in the depth slice 
or the GPR lines. 

 Concrete 3D Preview Example  

For the concrete grid shown in and below, the following observations can be made: 

1) The current depth slice shows a rebar or wire mesh at a depth of about 0.3 feet 
(using the depth scale on the X and Y Lines). 

2) The rebar is at a spacing of 6 inches (using Measure). 

3) A conduit with current flowing in it is visible in the depth slice, the X GPR Line 
and the PCD response. 
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 Utility 3D Preview Example  

For the utility grid shown in and below, the following observations can be made: 

1) The current depth slice shows two obvious utilities at a depth of about 0.5 meters 
(using the depth scale on the Y Line). 

2) The orientation of the utilities can be seen in the depth slice. 

3) Slicing through the depth slices shows other utilities at other depths and 
orientations. 
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10  Properties Tabs  
The Properties pane is a series of tabs that display information about the selected GPR 
line. The Properties pane can usually be found on the right side of the EKKO_Project 
screen; the tabs are displayed at the bottom of the pane. 

 

10.1  Acquisition Tab  

The Acquisition tab displays information about how the GPR line was acquired. It lists 
the survey parameters under four headings: General, Positioning, Advanced, and 
Additional Info. You may need to click the plus (+) sign to view the details under a 
heading.  
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To quickly open or close all the headings, click . 

 

 

 

Use the following tables to guide you through working with the Acquisition tab. 

The General pane displays the following basic survey parameters: 

Field Description 

Original Line Name The name of the GPR line when first opened in EKKO_Project. 

Comment Comment about the system used to acquire the data. 

Date Collected The date of data collection. 

Survey Type GPR survey type: reflection, CMP/WARR, or transillumination. 

Frequency (MHz) The antenna center frequency 

Time Window (ns) The length of the time window in nanoseconds (ns). 
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The Positioning pane displays the following parameters related to the positioning of the 
GPR line:  

Field Description 

Units Meters or feet 

Start Position The initial position of the GPR system along the line, generally will be 

zero, but could be different if an offset was used, or if the line was 

collected as part of a forward/reverse grid. 

End Position The ending position of the GPR system along the line 

Step Size The distance interval along the surface between GPR data traces 

Odometer Cal. The calibration value of the odometer wheel (if applicable) 

 

The Advanced pane displays the following advanced survey parameters:  

Field Description 

Number of Traces Total number of traces 

Points per Trace The number of sample points per trace 

Antenna Separation Spacing between transmitting and receiving antennas 

Stacking Type ¶ DynaQ ON: indicates automatic stacking 

¶ P: number of point stacks 

¶ S: number of trace stacks 

¶ A: maximum number of stacks 

Stacks Number of repeated measurements averaged to get resulting 

measurements 

Time Sample Interval 

(ps) 

The time period in picoseconds at which the GPR signal is sampled. 

Often set automatically by the system based on GPR frequency. 

First Break Offset (ns) The number of nanoseconds from the start of the trace to the first 

break 

Transmitter Voltage The voltage of the transmitter 

Pulse Width (ns) The width of the GPR pulse in nanoseconds. Varies with antenna 

center frequency. 

GPS Latency (s) The GPS latency in seconds (only listed if a non-zero value applied) 

GPS X Offset X direction offset between GPR and GPS (only listed if non-zero value 

applied) 

GPS Y Offset Y direction offset between GPR and GPS (only listed if non-zero value 

applied) 

GPS Z Offset Z direction offset between GPR and GPS (only listed if non-zero value 

applied) 

The Additional Information pane may include the serial numbers of the GPR system 
and the Digital Video Logger (DVL), as well as any processing done prior to importing 
the data. 
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10.2  Attachments Tab  

The Attachment tab lists all files attached to the current GPR line, project, grid, or lineset 
such as GPS files, topography files, photos, documents, videos or voice recordings of 
information relevant to the GPR line. 

 

 

 

 

 Attachments Toolbar  

Use the following table as a guide to working with the Attachments pane toolbar:  

Item Description 

 

Click to display or hide the list of attached files. 

 

This feature enables you to attach a file to the GPR line. 

1 Click Attach File. 

2 In the Attach File(s) dialog box, navigate to and select the file 

you want to attach. 

3 Click Open. 

Toolbar 
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1 In the Attachments tab, select the item you want to delete. 

2 Click Delete File. 

3 In the message box, click Yes. 

Note: Positioning files (GPS, Topography) cannot be deleted. 

 

1 In the Attachments tab, select the item you want to open. 

2 Click Open.   

Note: if there is no application associated with the selected file 

type, Windows will prompt you to select one from a list. 

 

 Positioning Files  

GPS and Topography files are special files called ñPositioning Filesò; they are always 
listed first in the Attachments list.  When attached, either automatically or manually, they 
cannot be deleted, only replaced by another GPS or topography file. 

If another GPS or topography file is attached, the user is prompted whether or not to 
replace the current file.  If they answer ñYesò, the new file is added to the list and the old 
GPS or topography file is appended with the extension .BAK and kept as an attachment 
for record-keeping but is not used for positioning. 

GPS and topography files both contain elevation information, but the topography file 
takes precedence.  Therefore, if both a GPS and topography file are attached, the 
topography file elevations are used when plotting the data. 

The GPS and topography file names must always match the name of the GPR line. If a 
GPS or topography file with a different name is manually attached to a GPR line, the 
name is changed to match the name of the GPR line.  Further, these attached files will 
be automatically renamed when the GPR line name is changed. Other attachments do 
not follow this requirement. 

10.2.2.1  GPS Files  

Attaching a GPS file adds Latitude, Longitude, UTM coordinates, and GPS elevation to 
every trace in the GPR line.   

A GPS file is created by attaching a GPS system to the GPR system during data 
collection. GPS files contain lines of standard GPS positional output text (called NMEA 
strings) and the associated GPR trace number. When the GPS (or GP2) file is attached 
to a GPR line, latitude, longitude, and GPS elevations for every GPR trace are 
calculated and saved into the GPR line. 

Some later GPR systems also save GP2 files, which contain GPS data in a different 
format than the GPS file.   

Note: EKKO_Project automatically creates a GP2 file from an existing GPS file. 

GPS and GP2 files formats are defined in Appendix B ï File Formats.  

When GPS information is available, GPR lines plotted in LineView display the GPS 
position of the current mouse cursor location on the Status Bar along the bottom of the 
screen.  
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When a GPS file is created with the same name as a GPR line in the project folder, the 
GPS file is automatically attached to the GPR line.  GPS files, even those with different 
names, can also be attached manually.  In this case the GPS file is copied, renamed to 
the same name as the GPR line and attached. 

A GPR line with integrated GPS is indicated by a small letter ñgò beside the GPR line 
name in Project Explorer. 

10.2.2.2  GPS Elevations  

GPS data contains an elevation value that is integrated with the GPR line. However, be 
aware that if you are using a lower-end GPS system the elevation data may not be very 
accurate; plotting the GPR line with an elevation axis in LineView usually provides poor 
results with large vertical shifts in the data image. High-end GPS systems can provide 
accurate elevation values that work well when the GPR line is plotted with an elevation 
axis in LineView.  

10.2.2.3  Topography Files  

A topography file is a text file containing GPR line positions and the elevations at those 
positions. When a topography file is attached to a GPR line, elevations for every GPR 
trace are saved into the elevation field of the GPR trace header.  

When elevation information is available, GPR lines can be plotted in the LineView 
module with an elevation axis. This type of display can be invaluable for understanding 
the proper spatial positioning of GPR reflections. 

¶ Each line of text must contain a pair of numbers representing position and elevation. 

Topography file example: 

0.0 935.8 

10.1 933.9 

22.7 930.3 

30.5 932.7 

34.6 936.5 

The Topography file format is defined in Appendix B ï File Formats. 

Note: Topographic files (.top) are stored in the same units that the data was collected 
in (meters or feet); however, the file could be viewed in a different unit. The units 
used during collection are displayed in the Acquisition tab Positioning Pane.  

1 



EKKO_Project Userôs Guide Properties Tabs 

 

 
51 

When a topography (.top) file is available with the same name as a GPR line in the 
folder, it is automatically attached to the GPR line.  Topography files, even those with 
different names, can also be attached manually.  In this case the topography file is 
copied, renamed to the same name as the GPR line and attached. 

A GPR line with integrated topography is indicated by a small letter ñtò beside the GPR 
line name in Project Explorer. 

If a topography file is attached after a GPS file is attached, the user is prompted to 
confirm whether or not they would like to replace the GPS elevations with the elevations 
from the topography file.  If the answer is ñYesò, the topography file is attached.  If the 
answer is ñNoò, the topography file is not attached.  In other words, if a Topography file 
has been attached, it is used for elevations.  
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10.3  Processing Tab  

If GPR lines have been processed using the optional Processing module, the processing 
details, including the name of the processes, the order the processes were applied, and 
the details of the process parameters are listed in the Processes tab. 

Only processed GPR lines are identified by a small letter ñpò in the Project Explorer will 
list processing information in the Processes tab.  

To learn more, see the Processing Module Userôs Guide. 

 

 

Note: Distance units (m/ft.) listed in the processes tab are always displayed in the 
format the GPR line was collected in, even if the Units have been changed in 
EKKO_Project. 
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11  Toolbars  
To manage how toolbars are displayed ion EKKO_Project, in the menu bar, click the 
View Menu. 

11.1  Standard Toolbar  

The EKKO_Project Standard toolbar displays icons or text that represents features that 
allow you to work with GPR data. 

 

Use the following table as guide to work with the Standard Toolbar: 

Toolbar Option Description 

New 

Click to create a New project. 

Open 

Click  to Open an existing project. 

Save 

Click  to Save the current project 

LineView 

Select an item(s) in Project Explorer and then click  to display the 

items in the optional LineView.module.   

The LineView button is only visible if a license for the LineView module was 

purchased.  

SliceView 

Select a grid or Line(s) in Project Explorer and then click  to 

display the grid as depth slices using the optional SliceView module.  

The SliceView button defaults to the SliceView-Grids.  To generate depth 

slices on GPR Lines, use the dropdown menu (small down arrow) on the 

side of the SliceView button:  

 

and select SliceView-Lines. 

3D Preview 

Select a grid in Project Explorer and then click  to display the grid 

as a depth slice flanked with an X and Y line in 3D Preview. 
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Toolbar Option Description 

PhotoSlicer 

Click the PhotoSlicer button  to open a photo and select the depth 

slices to superimpose onto the photo. See PhotoSlicer. 

Report Button to generate a report.  The Report button defaults to the GPR 

Summary Report but changes; remembering the last type of report 

selected.  To generate a different report than the one indicated by the 

button, use the dropdown menu (small down arrow) on the side of the 

button. 

 

The reporting options are:  

GPR Summary Report 

Google Earth (KMZ) 

Project Report (CSV) 

CAD (DXF) 

 

Bridge Deck Condition Report 

Pavement Structure Report. 

Process 

Click to open the Processing dialog box.   

The Process button is only visible if a license for the Processing module 

was purchased. See the Processing module Userôs Guide for more details. 

Undo Process 

Click  to Undo Processing applied to the checked GPR lines. 

The Undo Process button is only visible if a license for the Processing 

module was purchased. See the Processing module Userôs Guide for more 

details. 

Cut 

Click  to Cut  the selected or checked item(s) and place them on the 

clipboard. 

This enables you to remove a GPR line from a lineset and paste it into a 

different lineset. 

Note: a GPR line cannot be cut from a grid. 
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Toolbar Option Description 

Copy 

Click  to Copy the selected or checked GPR line(s), lineset, or grid, 

and place them on the clipboard. 

Paste 

Click  to Paste the cut or copied GPR line(s), lineset, or grid from the 

clipboard into the project. 

Delete 

Click  to Delete the selected GPR line, lineset, or grid from the 

project. 

Add or Remove 

Buttons 
Click the drop-down arrow beside the Delete icon  to add or remove 

buttons from the Standard toolbar. 

To learn more, see Add or Remove Buttons. 

To display a brief description of the iconôs function, hold your mouse cursor over the icon 
on the toolbar. 

If a keyboard shortcut is associated with the toolbar item, it is displayed with the tool tip  

 

A description also appears on the Status Bar at the bottom of the screen: 

 

 

11.2  View Control Toolbar  

The EKKO_Project View Control toolbar allows you to manage how to display images 
in MapView and Line Preview.  

 

 

Use the following table as a guide to working with the View Control toolbar: 

Field Description  

Zoom Out 

Click  to display 1.5 times more of the MapView image. 

For Line Preview, Zoom out shows more horizontal data in the window.  

To learn more, see Zoom Out. 
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Field Description  

Zoom In 

Click  to magnify the MapView image by 1.5 times. 

For Line Preview, Zoom in shows less horizontal data in the window.  

To learn more, see Zoom In. 

Zoom Window 

Click  to magnify a selected area within MapView or Line 

Preview.  

To learn more, see Zoom Window. 

Fit to Window 

Click  to automatically zoom to fit all data in the MapView or Line 

Preview windows. 

To learn more, see Fit to Window. 

Pan View 

Click  to pan the Display area (drag and drop) in MapView. 

Not available for Line Preview. 

To learn more, see Pan View. 

Measure 

Click  to measure distance in the MapView, Line Preview and 

3D Preview windows. 

To learn more, see Measure. 

View(s) Buttons to Save, Copy or Export the current image (see below).   

The View(s) button visible on the toolbar defaults to Save View(s) but 

changes; remembering the last type of View(s) selected.   

To select a View(s) option other than the one indicated by the button, 

use the dropdown menu (small down arrow) on the side of the button. 

 

Save View 

Click  to save the Active Window or all open windows as an 

image file and attach it to the project file.  This image can be included in 

the GPR Summary Report. To learn more, see Save View. 

Copy View 

Click  to copy the Active Window or both the MapView and 

Line Preview windows to the clipboard. 

To learn more, see Copy View. 
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Field Description  

Export View  

Click  to export the Active Window or both the MapView and 

Line Preview windows as a graphics image file (jpg, bmp, png etc.) 

To learn more, see.Export View. 

Add or Remove 

Button 

Click the drop-down arrow beside the View(s) button to add or remove 

buttons from the View Control toolbar. 

 

To learn more, see Add or Remove Buttons. 

 Measure  

To measure distance within the MapView, Line Preview or 3D preview windows, click 

. 

Click and drag the ruler icon ( ) to span two points within the MapView that you 
want to measure. 

The measured distance is displayed in the Status Bar on the bottom left: 

 

The first value indicates the straight-line distance between the two points. The values 
displayed in brackets represent the distance along the X-axis and Y-axis respectively. 
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12  Status Bar  
The Status Bar is displayed along the bottom edge of the EKKO_Project window: 

 

 

As the mouse cursor moves around the various windows and toolbars, relevant 
information is constantly displayed on the Status Bar including: 

Toolbars 

¶ Description of the function of the button 

¶ Measurement distance when the Measure button is selected (see Measure) 

Line Preview window: 

¶ Position along the GPR line 

¶ Depth 

¶ Trace number 

¶ Time 

MapView window: 

¶ Positional information in Project X,Y coordinates 

¶ Latitude/Longitude and UTM positions (see GPS Format) providing a Project-to-
Global position relationship has been defined (see Project Position Relationship) 
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13  Menu Bar Overview  
The EKKO_Project menu bar displays several options that allow you to create, save, 
manipulate, and export GPR data. 

 

Use the following table as a guide to working with the EKKO_Project menu bar: 

Field Description 

File Create a New project, or Open, Close, Save, Report, Export, or Exit 

existing projects. 

To learn more, see the File  menu. 

Edit  Update your project - add lines, linesets, or grids, rename files, or attach 

files. 

To learn more, see the Edit  menu. 

View Display units in meters or feet, view data in Average Amplitude 

Spectrum, Average Trace Amplitude or Trace Plot graphs, or define how 

the toolbars are displayed.  Perform CMP/WARR Analysis. 

To learn more, see the View  menu. 

Tools Access LineView (optional), SliceView-Grid and SliceView-Lines (optional), 

modify Project or Grid Position Relationships, Add Positioning to Lines, 

Processing (optional) and GPS routines. Add background image to 

MapView and Edit grids with the X and Y lines mixed up. 

To learn more, see the Tools  menu. 

Window To open the Line Preview or MapView windows or tile the Line Preview and 

MapView windows horizontally or vertically. 

To learn more, see the Window menu. 

Help Display information about EKKO_Project, a PDF version of this manual, the 

About dialog, and the EKKO_Project Registration.  See Help. 
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14  File Menu  
Use the File menu to create a New project, Open, or Save files, create Reports, Export 
lines, or Exit the EKKO_Project.  

To open the file menu drop-down list, click File: 

 

The following sections describe the File menu features: 

14.1  New  

1. To create a new project file, In the EKKO_Project menu bar, click File > New. 

Alternatively, in the Standard Toolbar, click .  

2. In the Getting Started dialog box (Figure 1), in the Create a New Project pane 
select one of the three data type options to add GPR data to a new project file:  

¶   
¶  
¶  

Note: Project files can contain multiple grids and linesets. 

To learn how to add more data to the current project file, see the Edit menu.  
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14.2  Open  

1. To open an existing project (.gpz) file in EKKO_Project, click File > Open.  

Alternatively, in the Standard Toolbar, click .  

2. In the Open dialog (Figure 2), navigate to and then select the project you want to 
open. 

3. Click Open. 

14.3  Close  

1. To close the current project click File > Close  
2. In the message box, to close the project and save your changes, click Yes. 

To close the project without saving your changes, click No. 
 

 

Figure 8: Save As dialog box 

3. In the Save As dialog box, navigate to the folder you want to save the project to. 
4. Click Save. 

14.4  Save  

1. To save the current project to a .gpz file, click File > Save. 

Alternatively, in the Standard Toolbar, click . 

2. In the Save As dialog box, navigate to the folder you want to save the project to. 
3. Click Save.  

When a new project is saved, the .dt1, .hd, and all other ancillary files such as GPS 
and topographic files are saved to a compressed .gpz project file. 
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14.5  Save As  

1. To save the current project to a different folder and/or name, click File > Save As.  
2. In the Save As dialog box, navigate to the folder you want to the project to. 

To save the project with a different file name, in the File name field enter the new 
project name.  

3. Click Save. 
 

14.6  Import GPZ  

 
1. To merge the data from an existing project (GPZ) file with the current project in 

EKKO_Project (if a project file is already open), click File > Import GPZ.  

2. In the Open dialog (Figure 2), navigate to and then select one or more projects (GPZ 
files) you want to import and merge into the current project. 

3. Click Open. 

4. Data folders and grids in the imported project files are added to the current project 
file.   

Note that no interpretations are imported from the project file into the current 
project. It is best to import and merge all the project files before adding interpretations 
or processing data.   
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14.7  Export  

Select Export to extract data files from a project and save them as GPR Line(s).   

If the optional Processing module is available, Export also allows GPR lines to be 
exported as Slices, Average Trace Amplitude (ATA) plots, and Average Frequency 
Spectrum (AFS) plots. 

1. To export data files, click Export. 

 

2. In the drop-down list, click the format you want to save the file as. 

 Line s 

Select Line(s) to extract data from a project file and save them to a separate folder as 
Line Data, CSV, or Text.  

1. Click the Line(s) drop-down list to select the format you want to export line data to: 
 

 
 

2. In the drop-down list, click the format you want to save the file in. 
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14.7.1.1  Line Data  

Select Line Data to export selected GPR lines (.dt1 or .hd) and any files attached to that 
data (such as GPS, topography, photos, etc.).  

1. To export GPR lines from the project (.gpz) file to a different folder location click File 
> Export > Line(s) >Line Data. 

 

2. In the Select folder to export to dialog box, navigate to and then select the folder 
you want to export the files to. 

3. Click Select Folder. 

A dialog box opens displaying the exported lines.  

\ 

Note: Interpretations are not saved when GPR lines are exported. 

The DT1 and HD file formats are defined in Appendix B ï File Formats.  
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14.7.1.2  SEG- Y 

Select SEG-Y to export GPR lines to a SEG-Y, a format commonly used for seismic 
data.  Selected GPR lines are converted to a file with the same name as the original 
file(s) appended with a .sgy extension, 

1. Click File > Export > Line(s) > SEG-Y. 
2. In the Select folder to export to dialog box, navigate to and select the folder you 

want to export the file to. 
3. Click Select Folder. 

A dialog box opens to display the folder that the .sgy lines were saved to. 
 

The SEG-Y format is defined in Appendix B ï File Formats.  

 

14.7.1.3  CSV 

Select CSV to export GPR lines to a comma separated value (CSV) file. This feature 
converts selected GPR lines to a single file with the same name as the original file(s) 
appended with a .csv extension, 

4. Click File > Export > Line(s) > CSV. 
5. In the Select folder to export to dialog box, navigate to and select the folder you 

want to export the file to. 
6. Click Select Folder. 

A dialog box opens to display the folder that the .csv lines were saved to. 
 

 

7. To open a .csv file, navigate to the folder you saved the lines in and then click the 
.csv file. 

The CSV files can be read by spreadsheet software such as Microsoft Excel and GIS 
packages. 
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The new file lists the data in a table that displays point amplitudes from each trace in 
separate columns with trace numbers and position values at the top of each column 
and point numbers and time values at the beginning of each row.  

 

Amplitude values are expressed as 2-byte integers ranging from -32767 to +32767 and 
can be converted to millivolts by multiplying by 50/32767 = 0.0015259. 

 

14.7.1.4  Text  

Select Text to export GPR lines to a text file. This feature converts GPR lines to a single 
text file with the same name as the original file(s) appended with a .txt extension. 

1. Click File > Export > Line(s) > Text  
2. In the Select folder to export to dialog box, navigate to and select the folder you 

want to export the file to. 
3. Click Select Folder. 

A dialog box opens to display the folder that the .txt lines were saved to. 
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4. To open a .txt file, navigate to the folder you saved the lines in and then click the .txt 
file.  

This format can be read by spreadsheet software, Microsoft Notepad, and WordPad. 
The text file lists data in a table that displays point amplitudes from each trace in 
separate columns with position values at the top of each column and time values at 
the beginning of each row.   

 

The first value in this file is a placeholder and is always set to -999. 

Amplitude values are expressed as 2-byte integers ranging from -32767 to +32767 and 
can be converted to millivolts by multiplying by 50/32767 = 0.0015259. 
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14.7.1.5  Tr ace Headers  

Every time a GPR data trace is collected, as well as saving the trace amplitude 
information, other parameters associated with that trace are saved to the ñtrace headerò 
in the data file.  

The trace header consists of 25 floating point numbers. Parameters such as the trace 
number, trace position, elevation data, Transmitter X, Y and Z positions, Receiver X, Y 
and Z positions, GPS X, Y and Z positions and the time of day in seconds past midnight 
when the trace data were collected, are saved to the trace header. 

If the GPR line was collected with a pulseEKKO system with a DVL-500, the 3-
dimensional orientation of the transmitter and receiver (Yaw, Pitch and Roll) are also 
listed.   

Exporting the trace headers allows the user to see the values of these parameters from 
every trace header in the GPR line.  

Select Trace Headers to export the GPR tracer header information to a CSV.  The 
selected GPR lines are converted to a file with the same name as the original file(s) 
appended with a .csv extension, 

1. Click File > Export > Line(s) > Trace Headers. 
2. In the Select folder to export to dialog box, navigate to and select the folder you 

want to export the file to. 
3. Click Select Folder. 

A dialog box opens to display the folder that the .csv lines were saved to. The CSV file 
format allows the trace header information to be exported to programs like Microsoft 
Excel. 
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14.7.1.6  Parameters  

Select Parameters to export the GPR Acquisition parameters for all the checked GPR 
lines to a CSV file.  The CSV file defaults to the name Line Parameters.  

1. Click File > Export > Line(s) > Parameters. 
2. In the Save As dialog box, navigate to the folder you want to save the CSV file of 

parameter data to. 
3. Modify the default file name if desired. 
4. Click Save. 

A dialog box opens to display the folder that the .csv lines were saved to. The CSV file 
format allows the data acquisition parameters to be exported to programs like Microsoft 
Excel. 
 

 
 

14.7.1.7  Point Cloud  

Third-party point-cloud software can be used for plotting very large scientific data sets.  
Originally developed for LiDAR, 3D Laser scans and photogrammetry, point cloud 
visualization software can be a useful tool for visualizing GPR data collected with GPS.   

Select Point Cloud to export the all the checked GPR lines to a point cloud CSV file.  
The CSV file defaults to the name Line Parameters.  

1. Click File > Export > Line(s) > Point Cloud 
2. In the Save As dialog box, navigate to the folder you want to save the CSV file of 

parameter data to. 
3. Modify the default file name if desired. 
4. Click Save. 

A dialog box opens to display the folder that the .CSV lines were saved to.  
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The CSV file format allows the GPR data to be imported into point cloud software such 
as CloudCompare and Voxler.  For example, the figure below shows a GPR line 
zigzagging over two utilities (indicated by hyperbolas) plotted in CloudCompare, free 3D 
point cloud processing software.   

 

 

 

GPR line data plotted in third -party point cloud software called CloudCompare .   
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 Slices  

This option requires the optional Processing module. 

Use the Slices feature to export Average Trace Amplitudes for one or more intervals 
from all the traces in the selected lines to a comma separated (.csv) file. Slices are 
compatible with 2D plotting software applications such as Golden Softwareôs Surfer. 

For more details, see the Processing Module Userôs Guide. 

 Average Trace Amplitude  

Select Average Trace Amplitude (ATA) plot to display the average rectified signal 
amplitudes (in microvolts) for one or more GPR lines.  

For more details, see Export Average Trace Amplitude Values. 

 Average Frequency Spectrum  

This option requires the optional Processing module. 

Select Average Frequency Spectrum (AFS) to display the average frequency 
spectrum of the selected GPR line(s).  

For more details, see Export Average Frequency Spectrum Values. 

 Attachments  

Select Attachments to export all the files attached to the project (GPZ) file.   

1. Click File > Export > Attachments. 
2. In the Select folder to export dialog box, navigate to and select the folder you want 

to export the file to. 
3. Click Select Folder. 
4. A dialog box opens to display the folder that the attachments were saved to. 

14.8  Recent Files  

1. To re-open a project (.gpz) file that you recently worked with, click File. 
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2. In the drop-down list, click one of the projects listed in the recent files area. 

14.9  Exit  

1. Click File > Exit to close all windows that are open as part of the current 
EKKO_Project session and exit the application. 

2. In the message box, click Yes to save the project file. 

  



EKKO_Project Userôs Guide File Menu 

 

 
76 
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15  Edit Menu  
The EKKO_Project menu bar Edit menu contains many features that allow you to add 
and update GPR project files. 

To open the edit menu drop-down list, click Edit: 

 

 

 

The following sections describe the Edit menu features: 

15.1  Add Grid  

1. To add a grid to the current project file, click Edit > Add Grid.  
2. In the Open dialog box, navigate to and then click the grid file you want to add. 
3. Click Open.  

The project file grid name defaults to the same name as the .gfp file.  

15.2  Ad d Lineset  

A Lineset represents a number of GPR lines grouped into a single folder. Select Add 
Lineset to create and then populate a lineset folder.  

1. Click Edit > Add Lineset. 
2. In the Select folder to import Lines From dialog box, navigate to and then select 

the folder you want to add.  
3. Click Select Folder. 

The lineset and lines are displayed in Project Explorer. 
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15.3  New Lineset  

Select New Lineset to create a New Lineset folder in the current project file. 

1. Click Edit > New Lineset.  

The lineset name appears in the Project Explorer window.  

 

15.4  Add Line(s) to Lineset  

Select Add Line(s) to Lineset to add lines to a Lineset in a project. 

1. Click Edit > Add Lines to Lineset.  

2. In the Open dialog, navigate to and then select one or more GPR (.hd) lines.  

3. Click Open. 

The data files are added to the Lineset and are displayed in the Project Explorer. 

15.5  Rename  

Select Rename to change the name of the project, grid, lineset, or GPR line in a lineset. 

Note: A GPR line name in a grid cannot be renamed. 

1. To rename an item, in Project Explorer, select the item you want to rename.  

 

2. In the menu bar, click Edit > Rename.  

 
A box appears around the item name signifying that the name is now editable. 

3. Type the new item name and then press Enter. 

Note: Certain characters, such as periods and slashes are not valid in names. If you 
enter one of these characters, it will be automatically replaced with an underscore. 

15.6  Attach File  

Select Attach File to attach GPS files, topography files, photos of the line location, 
videos of the area, or voice recordings of information relevant to the GPR project, grid, 
lineset, or line.  

1. To attach a file to the selected GPR data line, lineset, grid, or project, click Edit > 
Attach File. 

2. In the Attach Files dialog box, to navigate to and then select the file you want to 
attach. 

The file is listed in the Attachments tab. To learn more, see Attachments Tab.  
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15.7  Re move  

Use Remove > Interpretation Observations to remove interpretations from MapView 
and LinePreview. For example, since interpretations are included when a GPR line is 
copied, you may want to remove interpretations from the copied line.  

1. To remove interpretations from GPR line, lineset, or grid, click Edit > Remove > 
interpretation Observations.  

 
 
 

 

2. To remove the observation, in the message box, click Yes. 

15.8  Cut  

To remove the selected GPR line, lineset or grid from the project, click Edit > Cut. 

This enables you to remove a GPR line from a lineset and paste it into a different lineset. 

Note: a GPR line cannot be cut from a grid. 

15.9  Copy  

To copy an item, click Edit > Copy.   

Use the Copy feature to: 

¶ Copy a GPR line, lineset, or grid and display it in LineView or Process the item 
differently than the original. 

¶ Copy and then paste the selected lineset or grid back into the project. 

Note: GPR lines in a grid can be copied, but they must be pasted into a lineset; they 
cannot be pasted into a grid. 

15.10  Paste  

Select Paste to add a GPR line from one lineset to a different lineset.  

To paste an item, click Edit > Paste  

Use the Paste feature to: 
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¶ Paste a copy of a GPR line, lineset, or grid into LineView, or Process the item 
differently than the original. 

¶ Paste a copied or cut lineset or grid back into the project. 

Note: copied GPR lines must be pasted into a lineset; they cannot be pasted into a 
grid. 

15.11  Delete  

To remove a grid or lineset from a project, or delete a GPR line from the lineset in the 
project, click Edit > Delete. 

Note: GPR lines cannot be deleted from a grid.  

To delete a line or lines from a grid, use the GFP_Edit utility program that accompanies 
SliceView. 

Caution: Removing a GPR line from the project file may result in the total loss of the 
GPR data line, interpretations, and associated files (.gps, .top, and .ini) unless a 
separate copy of the original data files exists.  

The original data files may exist if the GPR lines were added to the project file rather 
than being embedded in the project (.gpz) file.  

If the project (.gpz) file was generated by the Sensors & Software GPR system, a copy 
of the GPR line(s) can be made clicking File > Export > Lines; this saves the original 
.dt1 and .hd files, and not the interpretations.  
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16  View Menu  
The EKKO_Project View menu contains many features that allow you to change the way 
information is displayed in EKKO_Project. 

To open the view menu, click View: 

 

 

The following sections describe how to work with the View menu features: 

16.1  Units  

1. To display units of measurement in EKKO_Project in meters or feet, click Units. 
2. In the drop-down list, click m (metric) or ft. (US standard).  

 

 

Changes in units of measurement affects the following EKKO_Project features: 

¶ Line Preview 

¶ MapView 

¶ LineView 

¶ Reports (including Bridge Deck Condition and Pavement Structure Reports) 

¶ Processing  
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16.2  Average Trace Amplitude  

Average Trace Amplitude (ATA) plots display the average signal amplitudes (in 
millivolts) for one or more selected GPR lines.  

ATA plots display how quickly signal amplitude decays from the peak value of the 
transmit pulse to the background noise level, providing an indication of the maximum 
penetration in the survey area. 

3.  Data is Dewowed and Rectified before being displayed but Dewow can be turned off 
(see   
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Filter).   
 
1. One GPR Line: To display the ONE currently selected GPR line in Project Explorer, 

right click with the mouse cursor on the Project Explorer window and then, from the 
right click menu, select Average Trace Amplitude Plot (ATA). 

 

 
 

2. Multiple GPR Lines: To display ALL the GPR lines currently CHECKED in Project 
Explorer, click View > Average Trace Amplitude Plot (ATA). 
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The ATA plot is greyed out if no lines are selected in the Project Explorer window. 
 

 
Figure 9: Average Trace Amplitude Plot 

Use the following table as a guide to working with the Average Trace Amplitude Plot: 
 

Item Description  

Resize Window Drag and drop a corner or edge of the window to resize it.  The 

Window can also be maximized using the Maximize button  in 

the top right. 

Pan View Hold the right-click button and drag the mouse in the direction you 

want to move the image. 

Copy Image to 

Clipboard 

Click the Copy Image to Clipboard to copy the image to paste it in 

another document. 

Default View Limits  Click Zoom - Fit to Window button to return to the original plot 

display. 

Zoom Click the image to define the top left corner of the zoom box 

1 Hold the left-click button and drag the mouse to the bottom 

right corner of the zoom box. 

2 Release the mouse button and the image zooms to the box 
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Item Description  

Amplitude (mV) ï Y 

Axis 

The GPR signal amplitude in millivolts (mV).  

Move the mouse cursor along the time axis to display the time and 

GPR signal amplitude on the status bar at the bottom of the window.   

The signal amplitude typically starts at the background noise level on 

the left.  At zero time, a strong amplitude signal occurs when the 

GPR system fires its transmitter. At later times, the GPR signal 

slowly decays back to the background noise level (providing the 

recording time window is long enough).  The steepness of the slope 

depends on the material being surveyed. 

Time (ns) ï X Axis The time in nanoseconds from the start of the recording window.  

Time before zero time is displayed as a negative value.   

The time at which the signal level drops back to the background 

noise level is the maximum penetration time. This can be converted 

to the average maximum depth of penetration if the GPR velocity for 

the material is known. 

 File  

Click the File menu to see the following sub-menu: 
 

 
 
 

Use the following table as a guide to working with the File menu: 
 

Item Description 

Print To print the ATA plot, click Print. 

Save Image as File To save the ATA plot as an image, click Save Image as File. 

1 In the Save As dialog box, use the dropdown at the bottom 

to select the type of graphics image file (jpg, bmp, gif or 

png). 

2 Navigate to the folder to save the file to. 

3 Click Save. 

Copy Image to 

Clipboard 

To copy an ATA plot image to paste to a document, click Copy 

Image to Clipboard.  

Save Image to 

Project 

To attach the ATA image to the project so it is included in GPR 

Summary Reports, click Save Image to Project.  
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Item Description 

Close To close the ATA plot, click Close. 

 Display  

Click the Display menu to see the following sub-menu: 
 

 
 

Use the following table as a guide to working with the Display menu: 
 

Item Description 

Legend Location To define the location of the legend on the ATA plot, click Legend 

Location. 

In the drop-down list click Top, Bottom, Left, Right, or Hide. 

Legend Select the items to include on the Legend: Filters and GPR Line 

names. 

Font Size Choose a font size of Small, Medium or Large. 

Linear Amplitude 

Axis 

Check this option to change the Amplitude Axis from the default 

Logarithmic scale to a linear scale. 

Custom Zoom Allows the user to specify Min and Max Times in nanoseconds 

(ns) and Min and Max Amplitudes in millivolts (mV) to display. 
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 Filter  

Click the Filter menu to see the following sub-menu: 
 

 
 

Check Background Average Subtraction to apply an Average background subtraction 
filter with a filter length equal to the length of the GPR line before plotting the ATA plot.  
Defaults to OFF.   

 
Check Dewow to apply a high pass temporal filter called Dewow to the GPR line before 
plotting the ATA plot.  Defaults to ON. 

 
For more information on Filtering, see Dewow and Background Average Subtraction in 
the Processing Module Userôs Guide. 

 Export Average Trace Amplitude Values  

Exporting the Average Trace Amplitude values requires the optional Processing module. 

To export the average rectified trace amplitudes for all the traces in the selected GPR 
line(s) to comma separated value (.csv) files: 

1. Click File > Export > Average Trace Amplitude (ATA). 

2. In the Select target folder for the ATA report dialog box, navigate to and then 
select a target folder. 

3. Click Select Folder  
A dialog box opens to display the folder containing the reports in Windows Explorer. 
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Note that the exported ATA data has the Dewow filter applied. 

16.3  Average Frequency Spectrum  

Average Frequency Spectrum (AFS) plots the average frequency spectrum of the 
selected GPR line(s).  

Plot the AFS to determine the frequency content of GPR lines to decide if filtering is 
required to remove unwanted frequencies like high frequency noise. If so, lowpass, 
highpass, or bandpass filtering can be applied (see Filters ï Time in the Processing 
Module Userôs Guide). 

Data is Dewowed and Rectified before being displayed but Dewow can be turned off 
(see   
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Filter).   

1. One GPR Line: To display the ONE currently selected GPR line in Project 
Explorer, right click with the mouse cursor on the Project Explorer window and 
then, from the right click menu, select Average Frequency Spectrum (AFS) 
Plot. 

 

2. Multiple GPR Lines: To display ALL the GPR lines currently CHECKED in 
Project Explorer click View > Average Frequency Spectrum Plot (AFS). 
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The AFS plot is greyed out if no lines are selected. 
 

 
Figure 10: Average Frequency Spectrum Plot 

 

Use the following table as a guide to working with the Average Frequency Spectrum 
Plot: 

Item Description  

Resize Window Drag and drop a corner or edge of the window to resize it.  The 

Window can also be maximized using the Maximize button  in 

the top right. 

Pan View Hold the right-click button and drag the mouse in the direction you 

want to move the image. 

Copy Image to 

Clipboard 

Click the Copy Image to Clipboard to copy the image to paste it in 

another document. 

Default View Limits  Click Zoom - Fit to Window button to return to the original plot 

display. 

Zoom Click the image to define the top left corner of the zoom box 

1 Hold the left-click button and drag the mouse to the bottom 

right corner of the zoom box. 

2 Release the mouse button and the image zooms to the box 

Amplitude (mV) ï Y 

Axis 

The GPR signal amplitude in millivolts (mV).  

Move the mouse cursor along the time axis to display the time and 

GPR signal amplitude on the status bar at the bottom of the window.   
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Frequency (MHz) ï 

X Axis 

The Frequency in megahertz (MHz).  

The displayed frequency range defaults to zero to the Nyquist 

frequency (calculated from the temporal sampling interval for the GPR 

line).    

 

Note: Sensors & Software antennas center frequency is measured in air. For 
example, 100 MHz antennas produce a center frequency of about 100 MHz when 
data is collected in air. The center frequency of data from antennas placed on the 
ground will be lower in frequency than the stated frequency of the antenna. For 
example, the center frequency of data collected with 100 MHz antennas is often 60 to 
70 MHz. 

 File  

4. Click the File menu to see the following sub-menu: 
 

 
 
 

Use the following table as a guide to working with the File menu: 
 

Item Description 

Print To print the AFS plot, click Print. 

Save Image as File To save the AFS plot as an image, click Save Image as File. 

1 In the Save As dialog box, use the dropdown at the bottom to 

select the type of graphics image file (jpg, bmp, gif or png). 

2 Navigate to the folder to save the file to. 

3 Click Save. 

Copy Image to 

Clipboard 

To copy an AFS plot image to paste to a document, click Copy 

Image to Clipboard.  

Save Image to 

Project 

To attach the AFS image to the project so it is included in GPR 

Summary Reports, click Save Image to Project.  

Close To close the AFS plot, click Close. 
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 Display  

5. Click the Display menu to see the following sub-menu: 
 

 
 

Use the following table as a guide to working with the Display menu: 
 

Item Description 

Legend Location To define the location of the legend on the AFS plot, click Legend 

Location. 

In the drop-down list click Top, Bottom, Left, Right, or Hide. 

Legend Select the items to include on the Legend: Filters and GPR Line 

names. 

Font Size Choose a font size of Small, Medium or Large. 

Linear Amplitude 

Axis 

Uncheck this option to change the Amplitude Axis from the default 

Linear scale to a logarithmic scale. 

Custom Zoom Allows the user to specify Min and Max Frequency in megahertz 

(MHz) and Min and Max Amplitudes in millivolts (mV) to display. 

 

 Filt er  

Click the Filter menu to see the following sub-menu: 
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Check Background Average Subtraction to apply an Average background subtraction 
filter with a filter length equal to the length of the GPR line before plotting the AFS plot.  
Defaults to OFF.   
 
Check Dewow to apply a high pass temporal filter called Dewow to the GPR line before 
plotting the AFS plot.  Defaults to ON. 

 
For more information, see Dewow and Background Average Subtraction in the 
Processing Module Userôs Guide. 

 Export Average Frequency S pectrum Values  

Exporting the Average Frequency Spectrum values requires the optional Processing 
module. 

To export the average frequency spectrum for all the traces in the selected GPR line(s) 
to comma separated value (.csv) files: 

1. Click File > Export > Average Frequency Spectrum (AFS). 

2. In the Select target folder for the AFS report dialog box, navigate to and then 
select a target folder. 

3. Click Select Folder  
A dialog box opens to display the folder containing the reports in Windows Explorer.  
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16.4  Trace Plot  

Trace Plot is used to display individual traces from one or more GPR lines; this allows 
the user to see subtle signals on traces or view the effect of different editing and 
processing types on individual traces. 

Viewing traces can also help you determine if the first break offset needs to be edited. 
Normally the first break should occur at the first large deflection in the signal. If not, time 
scales and depth scales on section plots will be inaccurate. 

1. One GPR Line: To display the traces of the ONE currently selected GPR line in 
Project Explorer, right click with the mouse cursor on the Project Explorer window 
and then, from the right click menu, select Trace Plot. 

 
 

2. Multiple GPR Lines: To display the traces of ALL the GPR lines currently 
CHECKED in Project Explorer, click View > Trace Plot. 
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The Trace plot is greyed out if no GPR lines are selected. 
 

 

Figure 11: View Traces Plot 

Use the following table as a guide to working with the Trace Plot: 
 

Item Description  

Resize Window Drag and drop a corner or edge of the window to resize it.  The 

Window can also be maximized using the Maximize button  in 

the top right. 

Pan View Hold the right-click button and drag the mouse in the direction you 

want to move the image. 

Copy Image to 

Clipboard 

Click the Copy Image to Clipboard to copy the image to paste it in 

another document. 

Default View Limits  Click Zoom - Fit to Window button to return to the original plot 

display. 

Zoom 1 Click the image to define the top left corner of the zoom box 

2 Hold the left-click button and drag the mouse to the bottom 

right corner of the zoom box. 

3 Release the mouse button and the image zooms to the box 

Amplitude (mV) ï Y 

Axis 

The GPR signal amplitude in millivolts (mV).  

Move the mouse cursor along the time axis to display the time and 

GPR signal amplitude on the status bar at the bottom of the window.   

Time (ns) The time in nanoseconds from the start of the recording window.  

Time before zero time is displayed as a negative value.    
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Trace The displayed trace.   

Click the up and down arrows to display other traces. 

Position The position of the displayed trace on the GPR line.  The position is 

based on the trace number and the step size 

 File  

3. Click the File menu to see the following sub-menu: 
 

 
 

Use the following table as a guide to working with the File menu: 
 

Item Description 

Print To print the Trace plot, click Print. 

Save Image as File To save the Trace plot as an image, click Save Image as File. 

1 In the Save As dialog box, use the dropdown at the bottom to 

select the type of graphics image file (jpg, bmp, gif or png). 

2 Navigate to the folder to save the file to. 

3 Click Save. 

Copy Image to 

Clipboard 

To copy a Trace plot image to paste into a document, click Copy 

Image to Clipboard.  

Save Image to 

Project 

To attach the Trace image to the project so it is included in GPR 

Summary Reports, click Save Image to Project.  

Close To close the Trace plot, click Close. 
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 Display  

4. Click the Display menu to see the following sub-menu: 
 

 
 

Use the following table as a guide to working with the Display menu: 
 

Item Description 

Legend Location To define the location of the legend on the Trace plot, click Legend 

Location. 

In the drop-down list click Top, Bottom, Left, Right, or Hide. 

Legend Select the items to include on the Legend: Filters and GPR Line 

names. 

Font Size Choose a font size of Small, Medium, or Large. 

Linear Amplitude 

Axis 

Not available. 

Custom Zoom Allows the user to specify Min and Max Time in nanoseconds (ns) 

and Min and Max Amplitudes in millivolts (mV) to display. 

 

 Filter  

Click the Filter menu to see the following sub-menu: 
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Check Background Average Subtraction to apply an Average background subtraction 
filter with a filter length equal to the length of the GPR line before plotting the Trace plot.  
Defaults to OFF.   
 
Check Dewow to apply a high pass temporal filter called Dewow to the GPR line before 
plotting the Trace plot.  Defaults to ON. 

 
For more information, see Dewow and Background Average Subtraction in the 
Processing Module Userôs Guide. 

16.5  CMP /WARR  Analysis  

This option requires the optional Processing module. 

Analyze Common Mid-Point (CMP) or Wide-Angle Reflection and Refraction (WARR) 
survey data (left) and analyze it using semblance analysis to extract velocity information 
(right): 

 

For more details, see the Processing Module Userôs Guide. 

16.6  Zoom  

 Zoom Out  

To decrease the magnification of the MapView or Line Preview image by a factor of 1.5 
times, click View > Zoom > Out. 

 Zoom In  

To increase the magnification of the MapView or Line Preview image by a factor of 1.5 
times, click View > Zoom > In. 
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When you zoom in to display a portion of the project data, an icon appears in the lower 
left corner of MapView to indicate that data exists outside the current view (see Pan). 

 Zoom Window  

To magnify a selected area of MapView or Line Preview windows, click View > Zoom > 
Zoom Window and then click and drag a rectangle in the area of interest. 

 Fit to Window  

To adjust the zoom to fit all the data in the MapView or Line Preview windows, click 
View > Zoom > Fit to Window. 

16.7  Pan  

To reposition the MapView or the Line Preview, click View > Pan.  

Click and drag the cursor ( ) to move the MapView or Line Preview within the 
window.  

 

 

Panning or zooming images within MapView may prompt the following icons to be 
displayed in the bottom left corner: 

Indicates that some of the data is outside the current window.   

Indicates that all of the data is outside the current window.  Click View > Zoom > 
Fit to Window to see all the data in the project in the MapView window. 
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16.8  Export Animation  

If the MapView or 3D Preview window is currently the Active Window, it can be saved to 
a GIF animation file by selecting View > Export Animation.  The following dialog box 
opens: 

 

 

 

Window displays the name of the window to be animated (MapView or 3D Preview). 

Cycle Through displays what images will animate.  If Window is MapView, it is only 
possible to animate the Depth Slices.  If the Window is 3D Preview, the user can select 
either the X Lines, Y Lines, or depth slices to animate. 

Speed determines the speed of the animation; the number of frames per second (fps).  
Slow is 1 fps, Normal is 2 fps and Fast is 3 fps. 

After pressing OK, the user is prompted to navigate to the folder to save the GIF file into 
and can edit the default name for the GIF file. 

After exporting the GIF animation file, the folder opens, to see the GIF file and play it, if 
desired. 

 




































































































































































































































